phone +7 (495) 66 014 66

× Вопрос/Ответ | Горячая линия

Акт Расхождения не делает движений в регистре Остатки ЕГАИС.

3 мес. 3 дн. назад - 3 мес. 3 дн. назад #7726 от Евгений
Добрый день. 1С: Управление торговлей алкогольной продукцией 8, редакция 11.3 (11.3.4.47)
Я так полагаю, что про вид акта "Акт Расхождения" разработчики просто забыли ?
Сначала столкнулись с проблемой, что при выгрузке в ЕГАИС ставится accepted, вместо differences. Ладно-победили, сняли с поддержки и сами пофиксили. Акт расхождения отправили в ЕГАИС, те его приняли, отправитель его подтвердил и остатки в ЕГАИС мы получили.
Но столкнулись со второй стороной проблемы (это код в ОбработкаПроведения):
ЭтоАктЗаПолучателя = ТоварноТранспортнаяНакладнаяЕГАИС.ВидДокумента=Перечисления.алкВидыДокументовЕГАИС.Исходящий И ВидДокумента=Перечисления.алкВидыДокументовЕГАИС.Исходящий;
	ЭтоВходящийАкт=ВидДокумента=Перечисления.алкВидыДокументовЕГАИС.Входящий;
	ЭтоИсходящийАкт=ВидДокумента=Перечисления.алкВидыДокументовЕГАИС.Исходящий;
	
	Если ЭтоАктЗаПолучателя Тогда //Акты за получателя
		Если ВидАкта=Перечисления.алкВидыАктовКТоварноТранспортнойНакладнойЕГАИС.АктОтказа Тогда
			ВыполнитьДвижение(Ложь,Истина, Ложь); //Расход, Сторно ТТН Исходящей, по данным ЕГАИС
		ИначеЕсли ВидАкта=Перечисления.алкВидыАктовКТоварноТранспортнойНакладнойЕГАИС.АктРасхождения Тогда
			ВыполнитьДвижение(Ложь,Истина, Истина); //Расход, Сторно ТТН Исходящей, по факту
		КонецЕсли;
		Возврат;
	КонецЕсли;
	
	Если ЭтоВходящийАкт Тогда // Акт от покупателя
		Если ВидАкта=Перечисления.алкВидыАктовКТоварноТранспортнойНакладнойЕГАИС.АктОтказа Тогда
			ВыполнитьДвижение(Ложь,Истина, Ложь); //Расход, Сторно ТТН Исходящей, по данным ЕГАИС
		КонецЕсли;
		Возврат;
	КонецЕсли;
	
	Если ЭтоИсходящийАкт Тогда // Акт поставщику
		Если ВидАкта=Перечисления.алкВидыАктовКТоварноТранспортнойНакладнойЕГАИС.АктПодтверждения Тогда
			ВыполнитьДвижение(Истина,Ложь, Ложь); //Приход, по данным ТТН входящей, по данным ЕГАИС
		КонецЕсли;
	КонецЕсли;
Акт Расхождения оформляется получателем на ВХОДЯЩУЮ ТТН, соответственно - условие, при котором Акт Расхождения даст движения в регистре остатков, никогда не сработает.
Ждать ли фикса? или снимать очередной модуль с поддержки и самим делать это?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

2 мес. 3 нед. назад - 2 мес. 3 нед. назад #7733 от Максим
А с чего Вы взяли, что акт расхождения должен делать движения? Разве в системе ЕГАИС после составления акта расхождения документооборот по ТТН завершается? Движение по регистру Вам сформирует подтверждение данного акта!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

2 мес. 3 нед. назад #7734 от Евгений
Дело в том, что даже после подтверждения Акта Расхождения он все равно остается "Актом расхождения", просто получает статус "Подтвержден".
Это не подходит ни под одно условие выполнения движений.
P.S. В любом случае уже пришлось лезть в модуль и прописывать то, что нам надо. Теперь остатки соответствуют тому, что принимает ЕГАИС.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

2 мес. 3 нед. назад #7735 от Максим
Статус "Подтвержден" у акта расхождения говорит о том, что его принял ЕГАИС.
Движения по регистру акт расхождения делать не должен, поскольку мы не знаем, согласится грузоотправитель с нашими изменениями или нет. Движения по регистру делает только подтверждение со стороны грузоотправителя на наш акт расхождений.
Поэтому те изменения, которые Вы сделали, они не нужны.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

2 мес. 3 нед. назад #7736 от Евгений
Я лично отправлял "Акт расхождения" от получателя и подтверждал его у грузоотправителя. Соответственно потом грузополучателем это подтверждение загружал. Все запросы\ответы отлично проходили через ЕГАИС и он всё принимал\подтверждал у себя. Остатков по справкам в регистре не появлялось

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

2 мес. 3 нед. назад - 2 мес. 3 нед. назад #7737 от Максим
Посмотрите движения у загруженного подтверждения к акту расхождений.

Судя по обработке проведения документа алкПодтверждениеАктаКТоварноТранспортнойНакладнойЕГАИС, они должны формироваться (и, честно говоря, формируются):
	...
	ИначеЕсли ВидДокумента = Перечисления.алкВидыДокументовЕГАИС.Входящий И ВидПодтверждения = Перечисления.алкВидыПодтвержденийАктовКТоварноТранспортнойНакладнойЕГАИС.Подтверждение Тогда
		//Подтверждены расхождения, движения по фактическому количеству.
		
		Для Каждого ТекСтрокаТовары Из АктКТоварноТранспортнойНакладнойЕГАИС.Товары Цикл
			Движение = Движения.алкОстаткиВЕГАИС.Добавить();
			Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
			Движение.Период = Дата;
			Движение.Организация = Организация;
			Движение.ПунктРазгрузкиОрганизации = алкПунктРазгрузкиОрганизации;
			Движение.АлкогольнаяПродукция = ТекСтрокаТовары.АлкогольнаяПродукция;
			Движение.СправкаА = ТекСтрокаТовары.СправкаА;
			Движение.СправкаБ = ТекСтрокаТовары.СправкаБ;
			Движение.Количество = ТекСтрокаТовары.КоличествоФакт;
		КонецЦикла;
		
	КонецЕсли;

Поэтому акт расхождений и не формирует движений.

Другое дело, когда мы отправляем расхождения грузоотправителю, работающему на ПС ЕГАИС. Вот там да, подтверждения можно не ждать, поскольку фиксация происходит сразу.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

2 мес. 3 нед. назад #7738 от Евгений
Хорошо, Максим. Сейчас ожидается очередное перемещение и проверю весь механизм еще раз, уделю внимание подтверждению

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Модераторы: ВалентинаЕжов Дмитрий
Время создания страницы: 0.086 секунд