phone +7 (495) 66 014 66

× Вопрос/Ответ | Горячая линия

ЛВЗ, При отгрузке на экспорт не работает условие отбора по стране экспорта.

3 года 7 мес. назад #7787 от Сергей
При отгрузке на экспорт не срабатывают условия по стране экспорта задаваемое в РС.алкНалогообложениеАкцизамиОрганизаций
Поправить все можно и самим, но лучше в типовой сделать правильно.

Как вариант - может имеет смысл привязаться к признаку Страна таможенного союза?
Т.к. экспорт в ТС не облагается акцизом, а во все остальные страны - облагается.
Можно указывать и страны в явном виде, просто записей в регистре будет больше, да и все равно сейчас не работает.

Ошибки в функциях (просто нет условия в запросе по стране экспорта в запросе, хотя в РС есть измерение нужное):

Функция ПолучитьВидОперацииНалогообложенияАкцизом_НоваяВерсия(Номенклатура, Организация = Неопределено, ВидДокумента = "", ВидАкциза = Неопределено, НаЭкспорт = Неопределено, СтранаЭкспорта = Неопределено, БанковскиеГарантииПредставлены = Неопределено)

СтруктураВозврата = Новый Структура("ВидОперацииНалогообложения");
Если алкОбщегоНазначенияПовтИсп.алкПолучитьИдентификаторКонфигурации()<>"ЛВЗ" Тогда
Возврат СтруктураВозврата;
КонецЕсли;

Запрос = Новый Запрос;
Запрос.Текст=
"ВЫБРАТЬ ПЕРВЫЕ 1
| алкНалогообложениеАкцизамиОрганизаций.ВидОперацииНалогообложения,
| ВЫБОР
| КОГДА &ВидДокументаУказан
| И алкНалогообложениеАкцизамиОрганизаций.ВидДокумента ПОДОБНО &ВидДокумента
| ТОГДА 0
| ИНАЧЕ 1
| КОНЕЦ КАК Приоритет
|ИЗ
| РегистрСведений.алкНалогообложениеАкцизамиОрганизаций КАК алкНалогообложениеАкцизамиОрганизаций
|ГДЕ
| ВЫБОР
| КОГДА &ОрганизацияУказана
| ТОГДА алкНалогообложениеАкцизамиОрганизаций.Организация = &Организация
| ИНАЧЕ ЛОЖЬ
| КОНЕЦ
| И алкНалогообложениеАкцизамиОрганизаций.Экспорт = &НаЭкспорт
| И алкНалогообложениеАкцизамиОрганизаций.БанковскиеГарантииПредставлены = &БанковскиеГарантииПредставлены
| И алкНалогообложениеАкцизамиОрганизаций.Номенклатура В(&СписокУсловий)
|
|УПОРЯДОЧИТЬ ПО
| Приоритет";

СписокУсловий = Новый Массив;
ПолучитьСписокВышестоящихГруппВидОперации(СписокУсловий, Номенклатура);

//Группы номенклатуры и прочее
СписокУсловий.Добавить(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Номенклатура,"ВидНоменклатуры"));
СписокУсловий.Добавить(Справочники.ВидыНоменклатуры.ПустаяСсылка());
СписокУсловий.Добавить(Справочники.Номенклатура.ПустаяСсылка());
СписокУсловий.Добавить(Номенклатура);

Запрос.УстановитьПараметр("СписокУсловий", СписокУсловий);
Запрос.УстановитьПараметр("ОрганизацияУказана", ЗначениеЗаполнено(Организация));
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("НаЭкспорт", НаЭкспорт=Истина);
Запрос.УстановитьПараметр("БанковскиеГарантииПредставлены", БанковскиеГарантииПредставлены=Истина);
Запрос.УстановитьПараметр("ВидДокументаУказан", ЗначениеЗаполнено(ВидДокумента));
Запрос.УстановитьПараметр("ВидДокумента", "%" + ВидДокумента + "%");

Результат = Запрос.Выполнить().Выгрузить();

Если Результат.Количество() > 0 Тогда

СтруктураВозврата.ВидОперацииНалогообложения = Результат[0].ВидОперацииНалогообложения;

КонецЕсли;

Возврат СтруктураВозврата;

КонецФункции


И здесь тоже стран экспорта не возвращается, хотя должна

Функция ПолучитьСтруктуруДокументаДляОпределенияОперацийНалогообложенияАкцизом_НоваяВерсия(ДокументОбъект, МетаданныеДокумента, КонтрагентНерезидент)

СтруктураВозврата = Новый Структура("Организация, Экспорт, СтранаЭкспорта, БанковскиеГарантииПредставлены,Синоним");
Если алкОбщегоНазначенияПовтИсп.алкПолучитьИдентификаторКонфигурации()<>"ЛВЗ" Тогда
Возврат СтруктураВозврата;
КонецЕсли;

СтруктураВозврата.Вставить("Синоним",МетаданныеДокумента.Синоним);
Если МетаданныеДокумента.Реквизиты.Найти("Организация") <> Неопределено Тогда
СтруктураВозврата.Организация = ДокументОбъект.Организация;
КонецЕсли;

Если (МетаданныеДокумента.Реквизиты.Найти("ДоговорКонтрагента") <> Неопределено) И (ЗначениеЗаполнено(ДокументОбъект.ДоговорКонтрагента)) Тогда
ДанныеДоговора=ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ДокументОбъект.ДоговорКонтрагента,"РеализацияНаЭкспорт,алкБанковскиеГарантииПредставлены");
СтруктураВозврата.Экспорт = ДанныеДоговора.РеализацияНаЭкспорт;
СтруктураВозврата.БанковскиеГарантииПредставлены = ДанныеДоговора.алкБанковскиеГарантииПредставлены;
КонецЕсли;

Возврат СтруктураВозврата;
КонецФункции //

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Время создания страницы: 0.061 секунд